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Kdenlive - Free and open sources video editing
There are MANY other options and alternatives out there, I have tried a few and you should too. For the
purpose of this course, we will be using Kdenlive.

About Kdenlive (KDE Non-Linear Video Editor)
I have tried quite a few free video editors and have personally settled on Kdenlive, it run on Windows Mac
and Linux, so you should be able to use it regardless of which operating system you are using.

Perhaps more important for our needs, it has been designed to be friendly on lower spec computers (not
powerful or older ones.) Additionally, it has a simple work-flow that still produces an advanced level of
video editing without having to learn a thousand steps for each effect.

Install
To get your copy of Kdenlive, go to www.kdenlive.org and chose the ‘Download’ link and, for use using
Windows, choose “The Windows 19.12.3 install version.” to start your download. Note: the version
number (19.12.3) might change depending on when you download it vers when this document was created

Once completed, double click on the downloaded “.exe” file and run through the installation process.

System Specs

Basic specs

32bits or 64bits computers with a modern Processor (AMD64 or Intel mono/dual core systems).

A fast hard disc with more that 20Gb of free disc space.

A firewire interface for camcorder capture.

At least 1Gb of RAM.

Screen size : 1024x768 or more.

Any computer produced after 2005 should meet these requirements.

For advanced use and semi-professional work, recommend specs are:

AMD Phenom Quad-core processor.

4 Gb of RAM.

Three SATA disc for RAID-5 usage (Any Linux distribution offers RAID-5 without additional controller).

A recent video card with dual display.

http://www.kdenlive.org
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Setting up
Before we begin, let’s set a few things that will make it easier in the long run.

The following information has been modified from here:
https://userbase.kde.org/Special:MyLanguage/Kdenlive/Manual/QuickStart#Complete_manual

Kdenlive directory structure

The first step is creating a new (empty) folder for our new project. I will call it quickstart-tutorial/ in this
tutorial. Then get some sample video clips, or download them from here:

www.hobstar.io/taining/kdenlive

Or directly from here:

https://www.mediafire.com/file/a0doef5kmd42smx/kdenlive-tutorial-videos_resources.zip/file

Extract them to e.g. a “quickstart-tutorial” folder

The image above shows the suggested directory structure: Each project has its own file that then needs to
have media, usually from other locations, added to it.

(The tutorial from now on assumes that you use the sample videos provided, but it works with any.)

http://www.hobstar.io/taining/kdenlive
https://www.mediafire.com/file/a0doef5kmd42smx/kdenlive-tutorial-videos_resources.zip/file
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Using
The Interface

Here we can see the interface for Kdenlive with the default colour scheme. Normally you should use it with
one of the darker themes like “Breeze Dark” is much better on your eyes, but not so good for screenshots.
For this tutorial I will be using “Breeze” so that it’s easier to see. Let’s have a look at the Interface;

1: The ribbon
Click the words along the top to access different options and actions

2: Project Bin
Add and view media added to your project. Media can be videos, audio (including music and voice
recordings) and images. Drag media from here onto your timeline (6)

3: Properties
This area changes to show the options for effects that you have added to your media

4: Effects
Look through different effects then drag and drop them onto the media in your timeline

5: Monitor
Shows a preview of what your finished video will look like. Use this to see how different effects looks

6: Timeline
The main working area. Media and effects are added here and worked on
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Editing the Interface
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The process
Lets have a look at creating a video

The following information has been modified from here:
https://userbase.kde.org/Special:MyLanguage/Kdenlive/Manual/QuickStart#Complete_manual

Create a new project
Open Kdenlive and create a new project (File -> New)

Choose the previously created project folder
(quickstart-tutorial/) and select an appropriate project
profile. The video files provided above are 720p, 23.98
fps. If you are using your own files and don’t know
which one to use, Kdenlive will suggest an appropriate
one when the first clip is added, so you can leave the
field on whatever it is.
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Adding clips
Now that the project is ready, let’s start adding some clips (i.e. the ones you
downloaded). This works via the Project Bin widget; a click on the Add Clip or
Folder icon directly opens the file dialog, a click on the small arrow shows a
list of additional clip types that can be added as well. Video clips, audio clips,
images, and other Kdenlive projects can be added via the default Add Clip or
Folder dialog.

An alternatively, and probably easier way to bring media into your project is to pen the folder where your
files are and dragging them into the Project Bin.
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Kdenlive window with the tutorial files
After loading the clips, Kdenlive will look similar to the image below. On the top left there is the already
known project tree. Right of it are the monitors that show video; The clip monitor displays video from the
original clips, the project monitor shows how the output video will look, with all effects, transitions, etc.
applied. The third, also very important, item is the timeline (below the monitors): This is the place where
the video clips will be edited. There are two different types of tracks, Video and Audio. Video tracks can
contain any kind of clip, audio tracks as well – but when dropping a video file to the audio track, only the
audio will be used.
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Saving a Kdenlive project
Let’s save the work via File -> Save As. This saves our project, i.e. where we placed the clips on the timeline,
which effects we applied, and so on. It can not be played. The process of creating the final video is called
Rendering.
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Timeline

Now comes the actual editing. Project clips are combined to the final result on the timeline. They get there
by drag and drop: Drag some Napoli (assuming you are using the files provided above, as in the rest of this
quick start tutorial; If not, please make sure your screen is waterproof, and perhaps tomatoproof) from the
project tree, and drop it onto the first track in the timeline.

Since some cutlery is needed as well, grab the spoon clip and drop it on the first track as well. Then drag
the Napoli to the beginning of the timeline (otherwise the rendered video would start with some seconds
of plain black), and the Spoon right after the Napoli, such that it looks like in the image on the left. (Where I
have zoomed in with Ctrl + Wheel.)

Timeline cursor

The result can already be previewed by pressing Space (or the Play button in the project monitor). You will
see the Napoli directly followed by a Spoon. If the timeline cursor is not at the beginning, the project
monitor will start playing somewhere in the middle; you can move it by dragging it either on the timeline
ruler or in the project monitor. If you prefer keyboard shortcuts, Ctrl + Home does the same for the
monitor that is activated. (Select the Project Monitor if it is not selected yet before using the shortcut.)
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Resize marker

Since after eating comes playing, there is a
Billiards clip. Add it to the timeline as well. For
the first 1.5 seconds nothing happens in the
clip, so it should perhaps be cut to avoid the
video becoming boring. An easy way for this is
to move the timeline cursor to the desired
position (i.e. the position where you want to
cut the video), then drag the left border of the
clip when the resize marker appears. It will
snap in at the timeline cursor when you move
close enough.

Overlapping clips

To add a transition between eating (the Spoon) and
playing billiards, the two clips need to overlap. To be
precise: the second clip should be above or below the
first one and end some frames after the second one
begins. Zooming in until the ticks for single frames
appear helps here; it also makes it easy to always have
the same transition duration, five frames in this case.

You can zoom in by either using the zoom slider at the
bottom of the Kdenlive window, or with Ctrl +
Mousewheel. Kdenlive will zoom to the timeline cursor,
so first set it to the position which you want to see
enlarged, then zoom in.

Transition marker

Now that the clips overlap, the transition can be added.
This is done either by right-clicking on the upper clip and
choosing Add Transition or, easier, by hovering the
mouse over the lower right corner of the Spoon clip until
the pointing-finger pointer is shown and the message
"Click to add composition" appears.

The latter, by default, adds a dissolve transition, which is
in this case the best idea anyway since the Spoon is not
required for playing.

The dissolve transitions fades the first clip into the second one.
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Let’s now add the last clip, the Piano, and again apply a wipe transition. When adding it on the first track of
the timeline, you need to click on the new clip’s lower left edge to add the transition to the previous clip.

Effects

Effect List
The Piano can be colourised by adding an effect to it. Select the piano clip, then double-click the RGB
Adjustment effect in the Effect List. If it is not visible, you can get it via View -> Effect List.

Once the effect has been added, its name will be added to the timeline clip. It will also be shown in the
Properties widget.
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Effect Stack with RGB adjustment

To get a warm yellow-orange tone on the image, fitting the comfortable evening, blue needs to be reduced
and red and green improved.

The values in the Properties widget can be changed by using the slider (middle mouse button resets it to
the default value), or by entering a value directly by double-clicking the number to the right of the slider.

The Properties widget always refers to the timeline clip that is currently selected. Each effect can be
temporarily disabled by clicking the eye icon, or all effects for that clip can be disabled using the check box
at the top of the Properties widget (the settings are saved though), this is e.g. useful for effects that
require a lot of computing power, so they can be disabled when editing and enabled again for rendering.

For some effects, like the one used there, it is possible to add keyframes. The [+] icon indicates this.
Keyframes are used for changing effect parameters over time. In our clip this allows us to fade the piano’s
colour from a warm evening colour to a cold night colour.
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Keyframes for effects

After clicking the keyframe icon (the [+] icon framed in
the previous image), a new keyframe will be added at
the point on the properties timeline where it was
positioned at the time of clicking. One added, this new
keyframe can easily be repositioned simply by clicking
and dragging, lets move it to the end/ far right.

Make sure the last keyframe is selected in the
Properties list. Then you are ready to flood the piano
with a deep blue.

Moving the timeline cursor to the beginning of the project and playing it (with Space, or the Play button in
the Project Monitor), the piano should now change the colour as desired.

Keyframing was the hardest part of this tutorial. If you managed to do it, you will master Kdenlive easily!

Music

Audio fadeout

Since the clips do not provide any
audio, let’s search for some nice piece
of music, from your local collection or
on web pages like BenSounds. The
audio clip should, after adding it, be
dragged to an audio track on the
timeline.

The audio clip can be resized on the
timeline the same way as video clips
are. The cursor will snap in at the end
of the project automatically. To add a fade out effect at the end of the audio clip (except if you found a file
with exactly the right length) you can hover the top right (or left) edge of the timeline clip and drag the red
shaded triangle to the position where fading out should start.
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Rendering

Rendering dialog
A few minutes left, and the project is
finished! Click the Render button (or
go to Project -> Render, or press Ctrl
+ Enter) to get the dialog shown on
the left. Select the desired output file
for our new video with all effects and
transitions, choose MP4 (works
nearly everywhere), select the output
file location and press the [Render to
File] button.

Rendering progress
After some seconds rendering will be finished, and your first Kdenlive project completed. Congratulations!
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Tutorials
Some suggested tutorial for you to check out AFTER you have completed the course are listed below.
Come back later and check them out

https://www.youtube.com/watch?v=yxxilfDTPK0&list=PLqazFFzUAPc7uQaoGxYwxGLk4_6fQrBvE

https://www.youtube.com/watch?v=ZUTPVtIeafc

https://www.youtube.com/watch?v=yxxilfDTPK0&list=PLqazFFzUAPc7uQaoGxYwxGLk4_6fQrBvE
https://www.youtube.com/watch?v=yxxilfDTPK0&list=PLqazFFzUAPc7uQaoGxYwxGLk4_6fQrBvE
https://www.youtube.com/watch?v=yxxilfDTPK0&list=PLqazFFzUAPc7uQaoGxYwxGLk4_6fQrBvE
https://www.youtube.com/watch?v=yxxilfDTPK0&list=PLqazFFzUAPc7uQaoGxYwxGLk4_6fQrBvE
https://www.youtube.com/watch?v=yxxilfDTPK0&list=PLqazFFzUAPc7uQaoGxYwxGLk4_6fQrBvE
https://www.youtube.com/watch?v=yxxilfDTPK0&list=PLqazFFzUAPc7uQaoGxYwxGLk4_6fQrBvE


Page 16

https://www.youtube.com/watch?v=yxxilfDTPK0&list=PLqazFFzUAPc7uQaoGxYwxGLk4_6fQrBvE
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